Audio unter Linux

Startseite Foren Deutsches LiveCode-Forum Audio unter Linux

Schlagwörter: , ,

  • Dieses Thema hat 3 Antworten und 3 Teilnehmer, und wurde zuletzt aktualisiert vor 6 Jahren von Ingo.
Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #4031
      Ingo
      Teilnehmer

        Hallo LiveCoder

        Ich habe hier das Problem, dass unter Linux kein Sound abgespielt wird.

        play "sound.wav"
        bzw.
        

        play ac “sound.wav”

        verweigert unter Linux die Soundausgabe. Unter Windows funktioniert es. An welchem Rädchen muss ich da drehen?

        Vielen Dank für jeden Hinweis
        Ingo

      • #4033
        gfz
        Teilnehmer

          Hallo Ingo,
          sorry ich habe kein Linux mehr auf einem Rechner installiert aber lässt sich diese Datei bei Dir unter Linux generell abspielen? Vielleicht solltest Du den Pfad zur Datei angeben? Mit specialFolderPath etwa.

          Übrigens:
          Im Dictionary steht diese kurze Schreibweise play soundFile [looping] für iOS und Android. Für Windows, Linux und co. gibt es eine umfangreichere Variante dazu:
          play [filePath | type] [looping] [at point] [options xOptions]
          obwohl alles in eckigen Klammern optional zu sein scheint :-).
          LG,
          Georg

        • #4045
          Klaus Major
          Administrator

            Wenn der Sound “importiert” wurde, sollte diese Syntax funktionieren.
            Check mal “the result”, vielleicht ist das ja erhellend?

            play ac “der_sound.wav”
            answer the result

            Wichtig:
            LC unterstützt mit “play” auf dem Desktop nur unkomprimierte WAV und AIF Sounds,
            sowie das komprimierte AU Format.

          • #4046
            Ingo
            Teilnehmer

              Kurzer Zwischenstand:
              Der Pfad ist richtig gesetzt. Ob mit specialFolderPath oder als kompletter Pfad angegeben macht keinen Unterschied.
              Da es unter Windows funktioniert, dürfte es auch nicht an der Datei liegen.
              Mit ‘answer the result’ gibt es leider keine Ausgabe, nur ein leeres Fenster.
              Ich vermute mal, dass es am Soundsystem von Linux liegt. Ich werde mich mal etwas mit alsa und Co auseinandersetzen.

              LG
              Ingo

          Ansicht von 3 Antwort-Themen
          • Du musst angemeldet sein, um auf dieses Thema antworten zu können.