Fehlermeldung "Could not encode class bundle"

Startseite Foren Deutsches LiveCode-Forum Fehlermeldung "Could not encode class bundle"

Ansicht von 9 Antwort-Themen
  • Autor
    Beiträge
    • #7030
      wfr
      Teilnehmer

      Hallo,

      Bin ein LiveCode-Neuling und habe folgendes Problem:
      Beim Erstellen einer Standalone-App für Android bekomme ich folgende Fehlermeldung:

      https://drive.google.com/file/d/15KL8TOKkvQySa7QREMVr5OVf2NkBKA2j/view?usp=sharing

      Ich arbeite mit Win 10,
      LC 9.0.1 (rc 1) Community
      Android Studio 3.1.4

      Hier die Mobile Support Einstellungen:

      https://drive.google.com/open?id=1NHNZKULxDta2izcy8XcJVmhoyX7V17sN

      und die installierten Android Studio Komponenten:

      https://drive.google.com/open?id=1uE58UR0wgV4RMgNxa5dAiUcTWpjoLpd2

      Seht ihr einen Fehler? Was könnte ich noch ausprobieren?

      Danke
      Walter

    • #7034
      gfz
      Teilnehmer

      Wie sehen denn die Standalone-Einstellungen für Android aus?
      liebe Grüße
      Georg

    • #7036
      gfz
      Teilnehmer

      Übrigens, willkommen hier im Forum Walter!
      lieben Gruß
      Georg

    • #7038
      wfr
      Teilnehmer

      Hallo Georg!

      Vielen Dank für die nette Begrüßung!
      Habe LC erst vor kurzem entdeckt und finde es absolut fantastisch.

      Hier sind die Android-Standalone-Settings:

      https://drive.google.com/open?id=1gN_vdnej5K1sPqfnCDDPkVc_AHNKC-BC

      Danke!
      Walter

    • #7040
      gfz
      Teilnehmer

      Hallo Walter!
      Als Minimum Android Version hast Du 4.1 in den Standalone Einstellungen angegeben – das hast Du aber laut deinem Screenshot im Android Studio nicht installiert. Also entweder eine installierte Version von Android als Minimum angeben oder Jelly Bean im Studio nachinstallieren. Dann sollte es klappen. Wenn’s dann immer noch nicht funktioniert, kann es meiner Meinung nur noch daran liegen, dass deine App Dienste nutzen will, die du bei den Einstellungen in den Bereichen „Requirements“ bzw. „Permissions“ noch auswählen müsstest. Ich hoffe, dass ich dir weiter helfen könnte. Liebe Grüße, Georg

    • #7094
      wfr
      Teilnehmer

      Hallo Georg,

      Habe Android 4.1 nachinstalliert, hat aber leider nichts gebracht. Meine App ist eine simple App vom Typ „Hello World“, also nichts, was spezielle requirements oder permissions bräuchte.
      Könnte es evtl. an der Java-Version liegen?

      lg Walter

    • #7096
      Klaus Major
      Verwalter

      Soweit ich mich erinnere, benötigt LC für Android Java in Version 8.

    • #7102
      gfz
      Teilnehmer

      Hallo Walter, hast du eigentlich auch die „build-tools“ und die „Plattform-Tools“ mithilfe des SDK-Managers installiert? Liebe Grüße, Georg

    • #7106
      wfr
      Teilnehmer

      Hallo,

      Ich bin jetzt draufgekommen. Man muß die Java-Version 8_144 installieren.
      Jetzt funzt es!

      Danke für Eure Hilfe!

      lg Walter

    • #7184
      gfz
      Teilnehmer

      Hallo Leute!
      Scheinbar funktioniert die Entwicklung für Android unter LC nur mit bestimmten Kombinationen aus JDK und Android SDK Versionen. Gibt es da vielleicht eine offizielle Liste von den Schotten mit welchen Versions-Kombinationen es klappen sollte?
      liebe Grüße,
      Georg

Ansicht von 9 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.