LC findet Java nicht. HILFE

Startseite Foren Deutsches LiveCode-Forum LC findet Java nicht. HILFE

Ansicht von 29 Antwort-Themen
  • Autor
    Beiträge
    • #3767
      hajowosto
      Teilnehmer

      Hallo,

      meine Installation von LC findet keinen Javapfad, so dass ich keine Apps für Android erstellen kann.

      Ich bitte um hilfreiche Tipps.

      LG Hajo

    • #3784
      gfz
      Teilnehmer

      Hallo Hajo,
      auf welchem Betriebssystem arbeitest Du? Was hast du schon alles versucht? Hast du Haukes Buch? Welche LC Version hast du installiert und welche Java Version hast du am Rechner? Hast du deine Pfadumgebungsvariable um den Pfad zu deiner Javaversion erweitert?
      In diesem Blog wurde das Thema auch schon einige Male berichtet und behandelt. Schau mal, ob in einem der bestehenden Beiträge was für dich dabei ist.
      LG, Georg

    • #3788
      hajowosto
      Teilnehmer

      Hallo Georg,

      erst einmal vielen Dank für Deine Antwort.

      Ich arbeite mit windows 10, Home, 64 Bit.
      Ich habe LC 8.1
      Ich habe bereits 2x die neueste Javaversion installiert.
      In LC unter Preferences und bei mobile Support kann ich den Pfad zu Android einstellen.

      Danach finde ich: JDK Pfath: (non)

      Ich vermute, das hier der Pfad zu Java stehen müsste.

      Haukes Buch habe ich und auch die Ergänzung auf der Verlagsseite.

      Meiner Meinung nach habe ich alles so eingerichtet, wie die dort beschrieben wurde. Allerdings weicht mein ANdroi SDK Pfad von dem im Buch beschriebenen ab.

      Ich kann EXE.Dateien unter Windows erzeugen, Allerdings keine Android Apps.

      Folgende Fehlermeldung erscheint:
      "there was an error while saving the standalone application
      could not compile applications class"

      Eine Pfadumgebungsvariable habe ich nicht gesetzt, ich wüsste leider auch nicht wie 🙁

      Ich hoffe sehr, dass u mir helfen kannst.
      LG
      Hajo

    • #3807
      gfz
      Teilnehmer

      Okay, ich habe jetzt nicht Zugriff auf meinen Windows 10 Rechner, wo ich LC ebenfalls zum Laufen brachte - sobald ich das habe, kann ich dir vielleicht mehr helfen. Nur vorab - wenn du eine dos-Konsole öffnest und dort "java -version" eingibst, bekommst du da eine sinnvolle Ausgabe - also die aktuelle Version deiner Javainstallation? Falls nicht solltest Du deine PATH Umgebungsvariable um den Pfad zu deiner Javainstallation erweitern. Hier steht wie das geht:
      https://www.java.com/de/download/help/path.xml
      liebe Grüße,
      Georg

    • #3823
      hajowosto
      Teilnehmer

      Hallo Georg,
      danke für Deine superschnelle Hilfe.

      Tatsächlich habe ich in der DOS Console bei der Eingabe von Java Version KEINE sinnvolle Antwort erhalten
      Text: Fehler: Hauptklasse version konnte nicht gefunden oder geladen werden
      Usache: java.lang.ClassNot FoundExeption: version"

      Ich werde mal die Sache mit der Pafadsetzung versuchen. Kann ich eigentlich irgendwo in LC den Javapfad manuell setzen?

      Vielen Dank und
      LG Hajo

    • #3846
      gfz
      Teilnehmer

      Guten Morgen Hajo,
      Deiner Fehlermeldung würde ich entnehmen, dass java installiert ist und versucht wird das Programm "Version" zu starten. Wichtig wäre hier alles in Kleinbuchstaben einzugeben und das Minuszeichen vor dem Wort "version" - aber das nur für den künftigen Umgang mit java von der Dos-Konsole :-).
      Wie Du meiner Meldung in der Anfrage "Android SDK installieren" in diesem Forum entnehmen kannst (https://www.livecode-blog.de/forums/topic/android-sdk-installieren/) hatte ich auch Probleme "Mobile Support" unter "Edit->Preferences" zu erstellen. Beim Blick in diesen Menüpunkt auf meinem Windows 10 Rechner musste ich jedoch feststellen, dass die Einstellungen gelöscht wurden :-(. Bin also jetzt selbst wieder auf Anfang. Das muss dann wohl nach einem der Updates von 8.1.2 auf derzeit 8.1.8 geschehen sein.
      Ich melde mich wieder, sobald ich das selbst wieder gemeistert habe.
      Falls Du früher erfolgreich warst würde ich mich auch über eine Beschreibung deines Lösungsweges freuen :-). Aber jetzt erst mal den Sonntag mit der Familie genießen.
      Also ich wünsche auch Dir einen schönen Sonntag.
      LG,
      Georg

    • #3856
      hajowosto
      Teilnehmer

      Hallo Georg,meinen

      wieder einmal DANKE für die schnelle Antwort.

      Ich als alter DOS- Fuzzi hätte eigentlich das mit der Kleinschreibung wissen müssen :-))

      Habe es noch einmal versucht, aber wieder nur eine Fehlermeldung.

      Wenn mir tatsächlich etwas gelingt, sage ich natürlich sofort Bescheid, ich bin allerdings nicht wirklich optimistisch.

      Aus dem Link, den Du mir gegeben hast, hatte ich tatsächlich den Andriopfad herausgeklaut, obwohl ich durchaus nicht sicher bin, ob der korrekt ist, aber LC meckert nicht.

      Schönen (Rest) Sonntag wünsche ich Die und Deiner Familie, trotz des trüben Wetters.

      LG Hajo

    • #3869
      gfz
      Teilnehmer

      Hallo Hajo,
      bei mir hat es wieder geklappt, ohne zusätzliche Installationen - musste lediglich den Pfad zum Android SDK einfügen und Java wurde gleich mit erkannt, als der Pfad als korrekt akeptiert wurde.
      Funktioniert es bei dir mittlerweile?
      Ich bin damals so vorgegangen, dass ich den aktuellen Java Development Kit von Oracle installierte
      Hier der Startpunkt: (http://www.oracle.com/technetwork/java/javase/downloads/index.html).

      Dann habe ich von (https://developer.android.com/studio/index.html) ganz unten die gezippte Variante der Android SDK Command Line Tools runtergeladen und in einem Verzeichnis, dessen Pfad keine Leerzeichen enthält entzippt (C:\Users\ich\Documents\MyLiveCode\Android\sdk).

      Dann nach langem Suchen im Internet wie die Installation auf der Commandline funktioniert bin ich nach dieser Anleitung vorgegangen (https://stackoverflow.com/questions/17963508/how-to-install-android-sdk-build-tools-on-the-command-line) und hatte schließlich Erfolg.

      Mit dem Android-Sdk-Manager installierte ich die "build-tools", die gewünschten "platforms" (8,15,17 und 23) und die entsprechenden "platform-tools" und updates zu "tools". Also unter dem Verzeichnis "C:\Users\ich\Documents\MyLiveCode\Android\sdk" habe ich folgende Unterverzeichnisse:

      • build-tools
      • platforms
      • platform-tools
      • tools

      Diesen Pfad (C:\Users\ich\Documents\MyLiveCode\Android\sdk) habe ich dann unter "Edit->Preferences->Mobile Support" angegeben. Dieser wurde im Feld für "Location of Android development SDK root:" angenommen und "JDK Path:" wurde automatisch gesetzt {stand vor der Eingabe auf (None)}.
      Ich hoffe das hilft Dir weiter, falls Du noch nicht in der glücklichen Lage bist Android Apps zu erstellen.
      liebe Grüße,
      Georg

    • #3921
      hajowosto
      Teilnehmer

      Hallo Georg,

      ich kann zumindest einen Teilerfolg melden. LC erkennt jetzt Java. (Ich habe die alte Javainstallation gelöscht und eine neue Installiert).
      LC versucht jetzt auch eine App zu generieren, bricht dann aber mit einer Fehlermeldung ab

      "There was an Error while saving the standalone applivation could not encode class bundle"

      Sagt Die diese Meldung etwas?

      Deine beiden ersten Links waren sehr erfolgreich, dem letzten bin ich leider nicht gewachsen 🙁

      Ich hatte vor einiger Zeit schon einmal ein komplettes Android herunter geladen, mit dessen Hilfe ich auch die platforms herunterladen konnte, daerte zwar ewig, aber wenns sein muss.

      LG und DANKE

      Hajo

    • #3931
      gfz
      Teilnehmer

      Hallo Hajo!
      zunächst zum dritten Link meiner letzten Antwort und was du damit machen kannst:
      Wenn Du eine Dos-Eingabeaufforderung im "tools"-Verzeichnis deines android-sdk öffnest, kannst du mit den Angaben aus der ersten Antwort dieses Links deinen android-sdk updaten. Also in meinem Fall sitzt mein dos-prompt im Verzeichnis C:\Users\ich\Documents\MyLiveCode\Android\sdk\tools
      und nach Eingabe von "android list sdk --all" sehe ich alle verfügbaren "Pakete".
      Und mit "android update sdk -u -a -t x,y,z" - wobei x,y,z für die per Nummer ausgewählten Pakete steht kann ich bei bestehender Internetverbindung die entsprechenden Pakete updaten bzw. hinzufügen.
      Auf diese Weise habe ich eben die "build-tools", die gewünschten "platforms" (android-sdk-8, android-sdk-15, android-sdk-17 und android-sdk-23) und die entsprechenden "platform-tools" und updates zu "tools" auf den neuesten Stand gebracht bzw. hinzugefügt.

      Aber jetzt mal retour auf Start! Ich bin jetzt nicht mehr sicher, ob wir nicht aneinander vorbei "reden". Ich bin bisher davon ausgegangen, dass dein Android-SDK von LC zusammen mit Java nicht akzeptiert wird.
      Steht bei dir unter "Edit->Preferences->Mobile Support" neben dem Feld "Location of Android development SDK root:" der Pfad zu deinem Android-SDK und neben "JDK Path:" nicht mehr (None) sondern der Pfad zu deinem Java Development Kit?

      Die Fehlermeldung sagt mir leider nichts. Ich kann nur Vermutungen anstellen.
      1. Dir fehlen beim Android-SDK die zugehörigen "platform-tools" zu deinen ausgewählten "platforms".
      2. Dir fehlen beim Android-SDK die zugehörigen "build-tools".
      3. Die ausgewählte Android-Platform ist mit dem installierten JDK nicht kompatibel.

      Welche Einstellungen hast du den getroffen unter "File->Save As Standalone Application" für Android? Hast du auch für die anderen Betriebssysteme (Mac, Windows, Linux, etc.) die Häkchen bei "Build for:" entfernt?

      liebe Grüße,
      Georg

    • #3939
      hajowosto
      Teilnehmer

      Hallo Georg,

      erst einmal wieder herzlichen Dank.

      Also mein technischer Stand ist: ich gebe in LC unter "Preferences" und "Mobile Suppert" einen Pfad zu "Location of Android......." ein.

      Dieser Pfad wird akzeptiert und dann trägt LC unter "JDK Path" selbsttätig einen Pfad zu Java ein.

      Soweit, so gut. Zwar habe ich die Androidverzeichnisse nicht so wie Du dies beschrieben hast, allerdings scheint LC den Pfad zu akzeptieren.

      Ich entferne in LC unter "Files" und "Standalon Aplication Settings" die Häkchen von allen anderen Betriebssystemen außer Android. Dort setze ich keine besonderen Einstellungen, soweit ich mich noch erinnere setze ich die im Buch empfohlenen Settings.

      Wenn ich danach die "Save as Standalon Aplikation anklicke, fängt das Prg an zu arbeiten und bricht dann mit der erwähnten Fehlermeldung ab.

      Soweit der Stand.
      Ich hoffe und vermute, Du hast noch eine Idee 🙂

      LG Hajo

    • #3947
      gfz
      Teilnehmer

      Hallo Hajo,
      schau mal was ich da bei Prof. Google zu deiner Fehlermeldung gefunden habe!

      http://runtime-revolution.278305.n4.nabble.com/ERROR-Android-Could-not-encode-class-bundle-td4711090.html

      Sonst wäre für mich noch die Frage offen, ob du die Android Plattform tatsächlich installiert hast, auf die "Minimum Android Version" zeigt.

      Hoffe da ist was für Dein Problem dabei und du kannst deine App am Smartphone nutzen 🙂
      liebe Grüße,
      Georg

    • #3951
      hajowosto
      Teilnehmer

      Hallo Georg,

      nochmals herzlichen Dank für Deine Hilfe.
      Leider bin ich nicht wirklich in der Lage sowohl die Androi Installation zu durchblicken als auch mich durch die englischen Seiten zu "wühlen".

      Aber ich habe einen guten Bekannten, der zufälligerweise Engländer ist, der es gewohnt ist sich durch MS Texte zu "fressen" und sicherlich auch feststellen kann, wie es mir meiner Androidinstallation aussieht. Zur Unterstützung werde ich Deine Email mitnehmen.

      Dies wird allerdings nicht soooo schnell gehen, mal sehen.

      Trotzdem möchte ich mich sehr herzlich bedanken für die Superunterstützung die Du
      mir gewährt hast.

      Ich melde mich natürlich, wenn es neue Entwicklungen gibt.

      LG
      Hajo

    • #4454
      appTaurus
      Teilnehmer

      Hallo,

      Das Problem mit der Application class hatte ich unter macOS auch. Die Lösung war den Java Pfad im Android SDK auf den aktuelleren Java Pfad zu verlinken. Das android SDK kam mit Java 1.6. ich habe 1.8 installiert. Im android SDK Java Ordner den 1.6 umbenannt und eine Verknüpfung mit dem Namen jdk-1.6 (bzw. wie der jdk ornder im android Studio Ordner heißt) zum Pfad vom 1.8 erstellt.

      Danach konnte ich die android App problemlos bauen.

    • #4482
      hajowosto
      Teilnehmer

      Hallo appTaurus,

      vielen herzlichen Dank für Deinen Hinweis.
      Mein LC akzeptiert und findet den Javapfad, nachdem ich LC den "richtigen" Androidpfad bzw, Ordner "angeboten" habe.
      Leider bricht LC dann die Kostruktion einer Androidapp mit einer Fehlermeldung ab.
      Leider blöd für mich, da ich eine App für meine Handy basteln wollte.

      LG
      Hajo

    • #4487
      appTaurus
      Teilnehmer

      Hallo Hajo,

      ich glaube ich habe mich missverständlich ausgedrückt. Der JDK Pfad im Android Studio ist zwar richtig aber die JDK Version ist die Falsche um mit LC 8+ Android Apps zu bauen.

      Installiere die aktuelle JDK-Version, ändere den Ordernnamen im Android-Studio JDK-Pfad ab und setze stattdessen einen Link auf die neue Version. Der Linkname muss so lauten wie der ursprüngliche Ordername, also:

      z.B. Android kommt mit JDK-1.6
      Du benennst JDK-1.6 in JDK-1.6_old
      Dann erstellst du im gleichen Ordner einen Link der auf JDK-1.8 verweist, egal wo die liegt.
      Der Link muss den Namen JDK-1.6 haben.

      Dann kannst Du mit LC 8 für Android bauen.

      Gruß

      Kosta

    • #4626
      hajowosto
      Teilnehmer

      Hallo appTaurus,

      vielen Dank für die Klarstellung.
      Ich werde das mal probieren.

      Allerdings bin ich mit Baumaßnahmen (neue Küche, 4 neue Fußböden, neue Tapeten und neue Türen)
      momentan bis über beide Ohren voll 🙁
      (Als Rentner sollte man ja eigentlich Zeit haben aber wenn die liebe Frau gerne eine neue Küche möchte....)

      LG
      Hajo

    • #4711
      Zahni2004
      Teilnehmer

      Hallo ich habe heute mit Freude feststellen können das das Buch angekommen ist und ich wollte gleich los legen ich hatte schon eine einfache Taschenrechner App gemacht, hatte die auch schon für Windows installiert. Leider habe ich jetzt auch das Problem das mein JDK Path nicht erkannt wird ich habe kein Plan warum ich habbe auch schon das probiert was ihr gesagt hattet. Das was appTaurus gesagt hatte habe ich nicht hinbekommen, weil ich nicht weiß wo ich diesen Ordner umbennen solle.Hoffe ihr könnt mir und den anderen irgendiw helfen ich benutze Win 10, LC 8.1.9 und habe das komplette Android Studio mit der Version 3.0.1.

      Danke im Voraus

      LG

      Sebastian

    • #4715
      appTaurus
      Teilnehmer

      Hallo Sebastian,

      hast du im Android Studio unter den Einstellungen auch das Android SDK API Level 15 (Ice Cream Sandwich 4.0.3) installiert?

    • #4720
      Zahni2004
      Teilnehmer

      Ja das hab ich

    • #4751
      appTaurus
      Teilnehmer

      Ok, hier eine Anleitung für Windows 10.

      1. LC > 8.1.6 installieren

      2. Android Studio > 3.0 installieren

      3. JDK = 1.8.0_161 installieren (nicht einfach nur Java sondern das Java Development Kit) (HIER DER LINK: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html - Die Datei jdk-8u161-windows-x64.exe runterladen und installieren)

      4. In Android Studio SDK 4.0.3 (Api 15) installieren.

      5. LiveCode starten.

      6. In den Einstellungen (Edit>Preferences>Mobile Support) den Pfad für Android SDK eingeben (typischerweise C:\Users\*deinuser*\AppData\Local\Android\SDK)

      Wenn JDK 1.8.0_161 installiert ist erscheint unter JDK_Path dann C:\Program Files\Java\jdk1.8.0_161 (bzw. in deutsch C:\Programme\Java\jdk1.8.0_161)

      Das funktioniert nur mit dieser Version vom JDK!!!

      Ich hoffe das führt zum Erfolg 🙂

      Viele Grüße

      Kosta

    • #4753
      Zahni2004
      Teilnehmer

      Ich werde es nachher versuchen und hier berichten

    • #4755
      appTaurus
      Teilnehmer

      Es geht auch mit JDK1.8.0_162

    • #4757
      Zahni2004
      Teilnehmer

      Vielen Dank es hat alles geklappt dank der Idiotensicheren Anleitung.

      LG Sebastian

    • #5491
      Zahni2004
      Teilnehmer

      Hallo unszwar habe ich das Problem das es mal wieder nicht funktioniert ich habe es auch nochmal neuinstalliert aber es geht nicht. es gibt jetzt auch nur eine neuere jdk version

    • #5840
      Jan
      Teilnehmer

      Moin,
      hat hier einer n Plan mir evtl. weiter zu helfen?
      Bei mir wird Java ebenfalls nich gefunden!

      Windows 7
      Java jre1.8.0_171

      Ich hab hier schon alles durchgelesen und werd nich schlau draus.
      Schon zig mal Java deistalliert und wieder installiert.
      Ältere Versionen finde ich nich im Netz.

      Gruß Jan

    • #6818
      Jensi
      Teilnehmer

      Hallo,
      ich bin jetzt nach der Anleitung gegangen und bekomme es einfach nicht hin.
      Wird immer noch nicht akzeptiert. Ich habe das Buch gelesen und habe voll die Ideen für die Firma und das Ding will nicht funktionieren was ein sch...

      Gibt es noch ne andere Lösung

      Vielen Dank Jungs

    • #6856
      appTaurus
      Teilnehmer

      Hallo Jensi,

      zunächst mal unter welchem Betriebssystem arbeitet Du?
      Welche Livecode Version benutzt du?
      Hast du auch sicher das Java development kit und nicht nur das "Java plugin" installiert?

      Viele Grüße

      Kosta

    • #6863
      gfz
      Teilnehmer

      Hallo Jan und Jensi,
      Schaut doch noch Mal unter diesem Thema Antwort 4751 von Kosta an - das sollte eigentlich klappen! Wichtig ist dabei den "Java Development Kit" (JDK) zu wählen und nicht die "Java Runtime Environment" (JRE)!!!
      Gruß
      Georg

    • #6969
      Jensi
      Teilnehmer

      Hallo,
      danke für die Antworten.
      Also ich habe Windows 10 und 2 Laptops.
      Bei dem einen habe ich alle neuesten Versionen drauf gemacht und beim anderen habe ich mir alle alten Dateien wie es in der Anleitung (4751) steht runtergeladen und installiert.
      Ich hatte nur den Punkt 4."In Android Studio SDK 4.0.3 (Api 15) installieren." nicht richtig durchgeführt, denn ich kann jetzt endlich C:/Useres...usw. eintragen ohne das er mault.

      Das Doofe ist nur, beim compilieren zeigt er dann einen Fehler weil unter dem Pfad der Punkt: "JDK Path: (None)" steht.
      Also erkennt er irgendwas nicht.
      Das Problem habe ich mit beiden Laptops.

      Ist etwas schade aber ich bleibe jetzt erstmal nur bei Windows.

      PS. Ja es ist die JDK Installiert und nicht JRE

Ansicht von 29 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.