IDE Code Editor Syntax Highlighting

Startseite Foren Deutsches LiveCode-Forum IDE Code Editor Syntax Highlighting

Ansicht von 5 Antwort-Themen
  • Autor
    Beiträge
    • #27403
      xamsoftware
      Teilnehmer

        Hallo zusammen,
        schon seit einigen Monaten ist mir aufgefallen, dass im Code Editor der IDE, mal abgesehen vom Fettschreiben der Keywords am Anfang der Zeile, das Syntax Highlighting fehlt. Früher wurden ja auch properties zum Beispiel blau eingefärbt. Weis da jemand mehr? Oder wie ich wieder in die “farbige” Version zurückkomme? Siehe auch das Referenzfoto unter dem Link unten.

        Gruß,
        Max

        Bildschirmfoto

      • #27408
        Klaus Major
        Administrator

          Hallo Max,

          da ist aber kein Screenshot zu sehen!?
          -> https://www.mediafire.com/file/hyh78dv8h60hlzc/MediaFire_-_Getting_Started.pdf/file

          Gruß

          Klaus

        • #27415
          xamsoftware
          Teilnehmer

            Hallo Klaus,
            komisch, da habe ich wohl die falsche Datei erwischt… Hier sollte der richtige Link sein: Bildschirmfoto

          • #27416
            Torsten
            Teilnehmer

              Schau mal unter Preferences / Script Editor / Colorization.
              Da kann man wählen zwischen default / Revolution classic und No colorization.

              LG
              Torsten

            • #27418
              xamsoftware
              Teilnehmer

                Das habe ich schon versucht. Bei default sieht es aus wie im Screenshot, bei Revolution Classic fehlt nur die Fettschreibung der Keywords am Anfang einer Zeile und bei “No Colorization” ist kein Unterschied zu default zu erkennen. Ich habe auch schon LiveCode deinstalliert und neu installiert und sogar unterschiedliche Versionen ausprobiert, aber das hat nichts geholfen…

                • #27420
                  Torsten
                  Teilnehmer

                    Im Bug-Forum ist ein ähnliches Problem beim neuen Big Sur aufgetreten, vielleicht ist es bei Dir ähnlich: https://quality.livecode.com/show_bug.cgi?id=22897

                    Die Lösung besteht darin, den Font des Script-Editors zu wechseln (in dem Fall von Source Code Proi zu default).

                    Probier das mal.

                    LG
                    Torsten

                • #27427
                  xamsoftware
                  Teilnehmer

                    Tataa, DAS ist die Lösung! Klar, seit ich Big Sur nutze ist dieses Problem vorhanden, und jetzt ist es gelöst! Vielen Dank Dir!

                Ansicht von 5 Antwort-Themen
                • Du musst angemeldet sein, um auf dieses Thema antworten zu können.