iOS Apps

Schlagwörter: 

Ansicht von 9 Antwort-Themen
  • Autor
    Beiträge
    • #18261
      Artur93
      Teilnehmer

        Guten Abend zusammen 🙂

        Ich bin totaler Neuling beim programmieren, daher mal eine ganz doofe Frage;

        Ich habe die Community Edition von LiveCode, kann man damit iOS Apps erstellen ? Ich kann kein Häckchen unter dem iOS Reiter erstellen, weil dass nicht anklickbar ist.

        Freundliche Grüße
        Artur

      • #18266
        Torsten
        Teilnehmer

          Hi Artur,

          hier ein Link zum Thema: http://lessons.livecode.com/m/2571/l/23075-how-do-i-build-an-ios-application

          1. Du kannst Apps für IOS nur auf einem Mac erstellen
          2. Auf dem Mac muss XCode (das ist die Enwicklungsumgebung für Apple-Software) installieren (ist kostenlos)

          Liebe Grüße
          Torsten

        • #18273
          Artur93
          Teilnehmer

            Hallo Thorsten,

            ok, vielen Dank für die schnelle Antwort! 😀

          • #19088
            tehmann
            Teilnehmer

              Hallo,
              ich möchte eine IOS-App erstellen,. Ich habe livecode Indy lizensiert, mich heute als App developer angemeldet, Zertifikate erstellt.
              Nun möchte ich unter Mobile support meine Xcode Version angeben. Zuerst hatte ich Xcode Version 11.3 (aus dem App-Store) installiert und folgende Fehlermeldung erhalten:
              The chosen folder is not a valid iOS SDK
              Selected Xcode must have an iOS SDK among:
              8.2
              9.2
              10.2
              11.2
              12.1
              Dann habe ich aus den developer downloads Xcode Version 12.1 installiert, aber mit demselben Ergebnis.
              Was ist zu tun?

            • #19093
              tehmann
              Teilnehmer

                Ich bin’s nochmal, folgendes habe ich herausgefunden:
                die Xcode Version und die darin enthaltene SDK-Version sind nicht identisch.
                aktuelle Xcode-Version 11.3 und 11.2 haben iOS-SDK 13.2 dabei.
                Die iOS SDK-Version 12.1 kommt bei Xcode 10.1 vom Oktober 2018 mit.
                Livecode scheint also noch eine recht alte Version zu benötigen?

                Bevor ich diese nun installiere, liege ich mit meiner Vermutung richtig? Und hat diesbezüglich jemand Erfahrungen gemacht.
                Viele Grüße
                Thomas

              • #19095
                Klaus Major
                Verwalter

                  Hallo tehmann,

                  willkommen im Forum!

                  Gehe mal in LC ins Menü: Help und wähle „Release Notes“.
                  In dem PDF auf Seite 5 stehen die genauen Anforderungen für LC und iOS.

                  Ich hoffe, die sind noch aktuell, ich selber besitze kein Handy oder Tablet
                  und entwickle daher auch nicht für die mobile Platform.

                  Gruß

                  Klaus

                • #19114
                  tehmann
                  Teilnehmer

                    Hallo Klaus, danke,
                    Da steht genau das Gleiche drin, wie in der Fehlermeldung.
                    Aber hier habe ich die relevanten Daten jetzt gefunden:

                    FAQ


                    Ich habe xcode 10.1 installiert und die korrekte Adresse war bei mobile daten eingetrage ohne dass ich etwas händisch hhätte eingeben müssen.
                    Viele Grüße Thomas

                  • #19118
                    Klaus Major
                    Verwalter

                      Ah, dake für die URL, muss ich mir merken!
                      Schönes Wochenende euch allen!

                    • #19126
                      tehmann
                      Teilnehmer

                        DAmit man in den ios standalone application settings eine Profile zum Auswählen angezeigt bekommt, muss
                        man in der Keychain Access.app noch eine Reihe von Angaben machen. Siehe link:
                        http://lessons.livecode.com/m/4069/l/308242-how-do-i-create-a-development-profile-for-ios

                      • #19130
                        tehmann
                        Teilnehmer

                          Hallo FRage in die Runde:
                          Hat überhaupt schon mal jemand eine ios-App auf dem iPhone zum Laufen gebracht und in den App-Store hochgeladen???
                          NAchdem ich jetzt die o. g. downgrades durchgeführt habe und eine standalone ios-app erstellen konnte,
                          lässt sie sich nicht auf das iPhone übertragen. Folgende Fehlermeldung:
                          „Could not locate device support files. This iPhone is running IOS 13.3, which may not be supported by this version of Xcode.“
                          Also sollich wohl Xcode updaten, aber dann kann ich wieder in LiveCode keine IOS-Apps mehr erstellen??
                          Wie komme ich aus dieser Schleife raus?
                          Danke euch
                          Grüße Thomas

                      Ansicht von 9 Antwort-Themen
                      • Du musst angemeldet sein, um auf dieses Thema antworten zu können.