Meine Codes sind alle „Schwarz“ ?

Startseite Foren Deutsches LiveCode-Forum Meine Codes sind alle „Schwarz“ ?

Schlagwörter: 

  • Dieses Thema hat 6 Antworten und 3 Teilnehmer, und wurde zuletzt aktualisiert vor 2 Jahre von Ramon18.
Ansicht von 6 Antwort-Themen
  • Autor
    Beiträge
    • #24440
      Ramon18
      Teilnehmer

      Hallo Leute,

      ich bin neu hier und hab erst seit ein paar Wochen angefangen mich mit LiveCode auseinander zusetzen. Am Anfang war es so das wenn ich Befehle geschrieben habe diese sich farblich hervorgehoben haben jetzt ist es nicht mehr der fall und alles bleibt farblich gleich nämlich alles in Schwarz.
      Wollte Fragen ob Ihr wisst was da los ist oder Ideen habt was ich da machen kann.
      Würde mich sehr freuen wenn ihr mir da weiter helfen könntet.
      Ich habe einen MacBook Pro von Apple nur als Randnotiz.

      Danke für eure Unterstützung und hoffe dass ich schnell eine Antwort bekomme weil es echt anstrengt ist finde ich das alles plötzlich nicht mehr „farblich“ ist sondern alles gleich aussieht.

      Ramon

    • #24442
      Axwald
      Teilnehmer

      Hallo,

      Menü „Edit“, „Preferences“, Abteilung „Script Editor“ (links), Punkt „Colorization“ (rechts).
      Da sollte „Default“ gewählt sein, nicht „No Colorization“.

      Wenn das bereits so ist, und trotzdem nicht „coloriert“ wird, hat es Dir die Preferences zerschossen. Ein Bug, der existiert, seit es LiveCode gibt 🙂

      Die heißen „livecode7.rev“, und liegen irgendwo unter „/RunRev/Preferences/“. Wo das auf dem Mac ist – keine Ahnung. Gib das in die Message box ein:
      put revEnvironmentUserPreferencesPath()
      Das sollte den korrekten Pfad geben.

      LC beenden (!), „livecode7.rev“ => „livecode7.old“ umbenennen, LC neu starten, Bingo. Merken wo’s war, das wirst Du noch öfter machen 😉

      Viel Spaß!

    • #24444
      Ramon18
      Teilnehmer

      Danke für deine schnelle Antwort.
      Ich finde unter „Edit“ nicht den Punkt „Preferences“?

    • #24445
      Ramon18
      Teilnehmer

      Könntest Du mir noch einmal bitte helfen 🙂
      Bin echt am verzweifeln hahah
      Kann es auch was mit einem Updated zu tun von MacOS?

    • #24446
      Ramon18
      Teilnehmer

      Hab es gefunden … es war schon „Default“ ausgewählt.

      Den anderen Schritt als „Default“ schon ausgewählt war hab ich leider nicht verstanden…
      Könntest Du mir es noch einmal erklären 🙂

      Ramon

    • #24447
      Klaus Major
      Verwalter

      Falls du schon „Big Sur“ installiert hast, da gibt es soweit ein Problem mit einem Font, dessen Name mir aber leider nicht mehr einfällt.

      Meinst Du den Speicherort der „Preferences“ von LC?
      Den findest Du auch einfach mit der Message Box, gib das hier ein und schau,
      wo die Prefs auf Deinem Mac gespeichert sind:
      put the filename of stack "revpreferences"
      ENTER drücken und diese Datei löschen und LC neu starten.
      Hilft oft bei solchem Ungemach. 🙂

    • #24451
      Ramon18
      Teilnehmer

      Hab den Fehler gefunden „Font“ war nicht richtig eingestellt es war „Default“ausgewählt und hab es mal geändert zu „(Default)“ und dann ging es!
      Danke für Eure Bemühungen und wünsche Euch noch einen schönen Tag 🙂

Ansicht von 6 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.