Problem mit APK und Samsung S7

Startseite Foren Deutsches LiveCode-Forum Problem mit APK und Samsung S7

Ansicht von 4 Antwort-Themen
  • Autor
    Beiträge
    • #1026
      bonapart
      Teilnehmer

      Hallo zusammen,
      ich bin Anfänger in Sachen LiveCode. Dieses Tool habe ich mir nach teilweise Lektüre des Buches „Eigene Apps programmieren“ auf einen Win 8.1 PC installiert.
      Da ich für unseren Verein gern eine App mit News, Terminen und ggf. Mitgliederdatenbank erstellen würde, habe ich auch gleich eine Mini-App nach Buch erstellt. Einfach mit Uhr und einem Browserfenster/URL.
      Aus dieser Test-App konnte ich auch, nach Installation von JDK und Android SDK, eine Android APK erstellen. Alles nach Buch, auch die Standalone-Einstellungen. Keine Fehlermeldungen von LiveCode 8.1.3.
      Diese APK habe ich auf mein S7 kopiert, „unbekannte Datenquellen…“ erlaubt usw. und versucht, diese kleine Test-App zu installieren. Dies bricht ab mit der Fehlermeldung:
      „App kann nicht installiert werden – Paket ist möglicherweise beschädigt.“
      Was heißt das? Liegt das an der APK oder am Handy? Wer hat ähnliche Erfahrungen.
      Möglicherweise habe ich als Neuling was falsch gemacht, und auch noch nicht das ganze Buch gelesen. Ich möchte halt, bevor ich mich zeitlich intensiver damit beschäftige, die grundlegende Funktionalität testen mit einer ganz einfachen App. Und diese dann später schrittweise erweitern.
      Vielen Dank im voraus.

    • #1032
      gfz
      Teilnehmer

      Hi bonapart,
      ich hatte so eine Meldung, als ich verabsäumt hatte auf die passende API Version zu achten. Hast Du eine Android API Version gewählt die gleich oder kleiner jener deines S7 ist?
      LG,
      gfz

    • #1038
      bonapart
      Teilnehmer

      Hi gfz,

      vielen Dank.

      Wo stellt man das ein? Beim Installieren von Android SDK hatte ich mehrere Versionen angewählt. Im Buch sind auch mehrere angewählt. Und in den Standalone Einstellungen steht irgemdwo was mit Android Version 2.xxx
      Weiss ich auch nicht so genau. Auf dem S7 ist Android 7.0.
      Welches SDK sollte ich nehmen und wie stelle ich das ein bei der APK Erstellung?
      Da ich eine App für unseren Verein plane und dort jeder ein anderes Handy hat sehe ich schwarz, eine halbwegs für alle vernünftige App zu basteln. Oder in 20 verschiedenen Versionen …

      LG bonapart

    • #1040
      gfz
      Teilnehmer

      Guten Abend bonapart,
      gut dass Du das Buch hast. Mit den Anweisungen dort im Kapitel 16.3 sollte es eigentlich klappen. Beim Verlag gibt es noch eine Ergänzung dazu zum runterladen.
      Die wichtigsten Punkte daraus sind:
      – Java
      – Android SDK
      – APIs mit SDK-Manager laden
      – Minimum Android Version (je kleiner die Version, desto größer die Zahl der Nutzer – eventuell API 15 Minimum – API 8 ist dann wohl doch zu tief angesetzt)
      – Signing auf „Sign for development only“
      – Mobiltelefon vorbereiten (Developer Options freischalten)

      Die Fehlermeldung könnte meiner Meinung drei Ursachen haben:
      a) eingestellte minimale Android Version des APK ist höher als am Smartphone
      b) Signing ist nicht auf „Sign for development only“ gesetzt
      c) Developer Options am Smartphone wurden nicht freigeschalten

      Hoffe das führt bei dir zu einer erfolgreichen Installation am Smartphone
      LG,
      gfz

    • #1044
      bonapart
      Teilnehmer

      Hi gfz,

      wollte nur noch mal kurz melden, daß die APK nun auch auf dem S7 installiert ist. Habe im Standalone Mindest Android Version auf 4.0 geändert. Lag wohl daran.
      Allerdings läuft die App nicht wie gewünscht. Anstatt das im Buch beschriebene Beispiel …tagesschau.de im Browserfenster zu öffnen kommt folgende Fehlermeldung anstatt des Site-Inhalts: ERR CACHE MISS.
      Liegt sicherlich am Handy, oder? Habe auch nicht viel rumgebastelt und als LiveCode Anfänger auch noch einiges falsch gemacht.
      Wollte das nur mal melden, falls andere User das gleiche Problem haben sollten.

      Nochmals vielen Dank.

      Und bis zum nächsten Problem …

Ansicht von 4 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.